Bank of Manhattan

Online Banking System Requirements

Minimum Requirements for the Use of Online Banking Business and Personal

The following computer hardware and software has been approved to meet security and application requirements required for use of Online Banking Banking service:

  • An IBM-compatible or Macintosh computer with a modem (internal or external)
  • Internet connection through an Internet Service Provider
  • Adobe® Reader® version 6.0 or higher (to view online eStatements)

The following Operating Systems and Web browsers meet the requirements for Online Banking:

Operating System

Apple Inc.
Safari Browsers

Microsoft® Internet Explorer (IE) Browsers

Mozilla® Firefox

Chrome

Windows XP SP3

4.0 and higher

7.0, 8.0

13.0, 14.0

3.0 and higher

Windows Vista

4.0 and higher

8.0, 9.0

13.0, 14.0

3.0 and higher

Windows 7

N/A

8.0, 9.0

13.0, 14.0

3.0 and higher

Mac OS X 10.6 (Snow Leopard™)

4.0 and higher

N/A

13.0, 14.0

N/A

Mac OS X 10.7 (Lion™)

4.0 and higher

N/A

13.0, 14.0

N/A


Note:  Cookies and JavaScript must be enabled.

Your Browser must support HTML 4.0 and be 128 bit SSL and JavaScript enabled. If you're using a browser that is no longer compatible with Online Banking, you can often download a newer version of your browser at the Web site for the company that created the browser.

After you have completed the download and installation of a supported browser, return to the login page and log in.

Note: use of a beta versions of browsers or operating systems is not recommended.